How To Fix Facebook Videos Won’t Play On Sony Xperia Z2

Some Sony Xperia Z2 owners are facing issue to use the Facebook app on their phone. A lot of users have complained that Facebook videos won’t play on Sony Xperia Z2. When they click on a video on Facebook, it starts playing but after a few seconds, it stops giving a message “Sorry, an error has occurred”.

If you have Sony Xperia Z2, you also may face the same problem while playing video on Facebook. However, here are some potential solutions that you can try to solve Facebook videos won’t play on Sony Xperia Z2 problem.

See also- Improve Battery Life on the Sony Xperia Z2

Potential Solutions for Facebook videos won’t play on Sony Xperia Z2

Facebook Videos
Facebook Videos Won’t Play On Sony Xperia Z2

1. Open Settings on your phone > Apps > Facebook > tap Clear Cache and then try to play a video on Facebook on your Sony Xperia Z2. It may solve your problem temporarily.

2. You can try to skip the point where the video fails and see what happen.

3. Another temporary solution to this problem is uninstalling the Facebook app and again reinstalls it. But these three steps may solve the problem only temporarily.

4. Make sure that the Facebook app on your Sony Xperia Z2 has the latest update. You can check it by loading up the Play Store app, and then select My Apps which you will find in the menu on the left. Other than Sony Xperia Z2, this issue is also occurring on some other Android devices, which suggest that the Facebook app is the main problem.

5. Some users have found a solution to this problem by disabling one of the Sony’s pre-installed apps. To do that go to Settings > Apps > slide the screen and tap All tab > scroll down and tap to Xperia with Facebook. Select disable and then return to your Facebook. Now play a video there and see if the problem is solved.

If not, contact with the retailer from where you purchased the phone or Sony’s service center.

 

Total
0
Shares
3 comments
  1. I fixed it for Xperia Aqva M2,remove proxy server Settings->More->Mobile Networks->Access Point Names->Select your Access Point->Remove Proxy

  2. Ive tried all these and the video play back on facebook with my Z2 is still a hit and miss.. sometimes it loads the videos without problems,. and sometimes it still cuts off the clip prompting some unknown error as before.. -_- #annoyed

  3. Ive tried all these and the video play back on facebook with my Z2 is still a hit and miss.. sometimes it loads the videos without problems,. and sometimes it still cuts off the clip prompting some unknown error as before.. -_- #annoyed

Leave a Reply

Your email address will not be published. Required fields are marked *