Galaxy S4 Network disabled because internet connection is slow

Discussion in 'Samsung Galaxy' started by Guest, May 22, 2014.

  1. Guest

    Guest Visitor
    Visitor

    #2 Guest, May 22, 2014
    Last edited by a moderator: Mar 23, 2015
    <strong>How to Fix Galaxy S4 Network disabled because internet connection is slow</strong>

    Today i updated my Samsung galaxy S4 to Kitkat 4.4... I am trying to connect to a network but getting this error message each time i attempt " Network disabled because internet connection is slow"

    I am frustrated because my friend told me that there is a lot of bugs with Update 4.4
     
  2. chevypowell

    chevypowell Administrator
    Staff Member Administrator

    Feb 9, 2015
    171
    12
    27
    Male
    Knowledge Seeker
    #3 chevypowell, May 22, 2014
    Last edited by a moderator: Mar 23, 2015
    This problem is occurring because

    This problem is occurring because you have auto wifi switching and scanning on. Please turn on both to fix <b>Network disabled because internet connection is slow issue</b>

    > Navigate to settings
    >WIFI SETTINGS
    >Uncheck Notify me when network is available
    >Uncheck auto network switch AND scanning always option
     
  3. Anonymous

    Anonymous Visitor
    Visitor

    I have done all the

    I have done all the above and it still won't work. It makes the internet not work on my network. I know it's the phone causing it because the minute I turn wifi off on the phone the network works again.
     
  4. balaji

    balaji Visitor
    Visitor

    Please do the following two setting changes; it worked for me.
    1. Go to settings and then select More and disable the Locations.
    2. Go to settings and then select security and uncheck send security reports.

    Enjoy. Cheers!!!!!
     

Share This Page

Loading...