Cant unlock phone

Discussion in 'HTC' started by Guest, Mar 12, 2015.

  1. Guest

    Guest Visitor
    Visitor

    #2 Guest, Mar 12, 2015
    Last edited by a moderator: Mar 22, 2015
    Hey guys

    I just flashed 1.54 firmware and while doing it, I locked the phone. I flashed the firmware and everything works fine, but now i can't unlock it for some reason i'm S-OFF and my CID is 11111111. I tried the command to flash the token but no luck and have even tried getting a new token.

    Code:
    C:\Users\Mauricius\Desktop\platform-tools>fastboot flash unlocktoken Unlock_code.bin
    target reported max download size of 1830711296 bytes
    sending 'unlocktoken' (0 KB)...
    OKAY
    writing 'unlocktoken'...
    FAILED (remote: unlock token check failed)
    finished. total time: 0.129s


    Code:
    1|shell@htc_m8:/ $ echo -ne "HTCU" | dd of=/dev/block/mmcblk0p2 bs=1 seek=33796
    lock/mmcblk0p2 bs=1 seek=33796 <
    /dev/block/mmcblk0p2: cannot open for write: Permission denied
    1|shell@htc_m8:/ $
    C:\Users\Mauricius\Desktop\platform-tools


    Can someone help me please?
     
  2. Anonymous

    Anonymous Visitor
    Visitor

    You'll have to flash the

    You'll have to flash the STOCK Hboot for the Unlock_code.bin to work

    Also, if you flash the unsecure boot.img then you can send root (su) command line through adb shell to unlock that way

    To flash boot or recovery or Hboot just zip it together with your devices android-info.txt and named properly and flash through bootloader (like with splash1.img)
     
  3. puru2

    puru2 Member
    Staff Member Senior Member

    Dec 30, 2014
    54
    3
    8
    Male
    You will have to run

    You will have to run these commands in ADB

    fastboot erase cache
    fastboot oem rebootRUU
    fastboot flash zip 0P6BIMG.zip
    fastboot reboot

    Enjoy!
     

Share This Page

Loading...